Workbench unavailable
Incident Report for Expel, Inc.
Resolved
Workbench functionality is now fully restored.
Posted 5 months ago. May 29, 2019 - 14:08 EDT
Identified
Workbench is currently unavailable. We have identified the cause and are working on a resolution.
Posted 5 months ago. May 29, 2019 - 14:06 EDT
This incident affected: Workbench availability (Workbench login), Workbench features (Investigative actions, File uploads, Email notifications), and Alert ingestion.