Workbench Performance Degraded
Incident Report for Expel, Inc.
Resolved
Workbench performance degradation has been resolved.
Posted Dec 16, 2020 - 15:08 EST
Investigating
Workbench is experiencing delayed response times. We are investigating the issue.
Posted Dec 16, 2020 - 14:46 EST
This incident affected: Notifications (Email) and Workbench features (Investigative actions, File uploads).