Workbench Degraded Availability

Incident Report for Expel, Inc.

Resolved

The incident has been resolved, and all systems are once again fully available. No customer data was lost.
Posted Feb 19, 2025 - 09:41 EST

Investigating

At 8:30AM ET, we began experiencing a problem with our load balancing infrastructure that is causing workbench instability. We will provide an update by 10:30AM ET.
Posted Feb 19, 2025 - 09:32 EST
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login) and Workbench features (Investigative actions).