Workbench unavailable
Incident Report for Expel, Inc.
Resolved
Workbench is now fully working and all alerts are being processed.
Posted Jul 05, 2021 - 01:26 EDT
Investigating
Workbench is not currently loading data. We are investigating. We will provide an update by 1:45 AM U.S. Eastern time.
Posted Jul 05, 2021 - 01:16 EDT
This incident affected: Notifications (Email), Workbench features (Investigative actions, File uploads), and Alert ingestion.