Workbench response times degraded
Incident Report for Expel, Inc.
Resolved
All issues with Workbench load are resolved and all backlogs are caught up.
Posted Oct 27, 2021 - 19:56 EDT
Monitoring
We have implemented a fix to isolate the performance problem. General workbench functionality is working. No alerts were lost due to this issue and the backlog will be caught up soon. We will continue to monitor Workbench performance.
Posted Oct 27, 2021 - 19:37 EDT
Identified
Workbench response times are climbing and affecting overall workbench performance. We have identified the issue and are working on a fix.
Posted Oct 27, 2021 - 17:54 EDT
This incident affected: Notifications (Email) and Workbench availability (Workbench global network connectivity, Workbench login).