Workbench Availability
Incident Report for Expel, Inc.
Resolved
The incident has been resolved, and all systems are once again fully available. No customer data was lost.
Posted Jul 25, 2024 - 17:04 EDT
Monitoring
We have taken action to resolve the issue and are seeing signs of full recovery. We are monitoring the health of the Workbench application and will resolve this if there are no outstanding issues. Please let us know if you are experiencing any problems.
Posted Jul 25, 2024 - 15:01 EDT
Investigating
At 2 PM EDT, we began experiencing a problem with our Workbench application that is preventing the Expel SOC from logging into security devices and running investigative actions. We will provide an update by 3 pm EDT.
Posted Jul 25, 2024 - 14:33 EDT
This incident affected: Workbench features (Investigative actions).