Workbench Availability

Incident Report for Expel, Inc.

Resolved

The incident has been resolved, and all systems are once again fully available. No customer data was lost.
Posted Jan 27, 2025 - 17:08 EST

Update

We have rolled back to an earlier version of workbench. We are continuing to monitor the health of the infrastructure. Please let us know if you are experiencing any problems. Please expect another update by 5:00pm EST.
Posted Jan 27, 2025 - 15:57 EST

Update

Our change did not resolve the incident. We are rolling back to an earlier version of workbench. We are continuing to monitor the health of the infrastructure. Please let us know if you are experiencing any problems. Please expect another update by 4:00pm EST.
Posted Jan 27, 2025 - 15:40 EST

Update

We have identified a further issue and have rolled out an additional fix that we believe will resolve the incident. We are continuing to monitor the health of the infrastructure and will resolve this if there are no outstanding issues. Please let us know if you are experiencing any problems. Please expect another update by 2:30pm EST.
Posted Jan 27, 2025 - 14:31 EST

Update

We have identified a further issue and are rolling out an additional fix that we believe will resolve the incident. We are continuing to monitor the health of the infrastructure and will resolve this if there are no outstanding issues. Please let us know if you are experiencing any problems. Please expect another update by 2:30pm EST.
Posted Jan 27, 2025 - 14:12 EST

Update

We have implemented a fix and believe the incident to be resolved. We are continuing to monitor the health of the infrastructure and will resolve this if there are no outstanding issues. Please let us know if you are experiencing any problems. We will issue another update by 2pm EST.
Posted Jan 27, 2025 - 13:30 EST

Monitoring

We have implemented a fix and believe the incident to be resolved. We are monitoring the health of the infrastructure and will resolve this if there are no outstanding issues. Please let us know if you are experiencing any problems. Please expect another update by 1:30pm EST.
Posted Jan 27, 2025 - 12:46 EST

Investigating

At 11:49am EST, we began experiencing a problem with our authorization service that is preventing users from using workbench due to added latency. We will provide an update by 1pm EST.
Posted Jan 27, 2025 - 12:20 EST
This incident affected: Workbench availability (Workbench global network connectivity, Workbench login).