Slack messaging outage

Incident Report for Expel, Inc.

Resolved

Slack has confirmed that their systems are fully operational now. Our service remains fully operational
Posted Feb 26, 2025 - 19:50 EST

Update

Following up on today’s Slack outage–We are seeing indications that Slack service has been restored, but we’re continuing to monitor as some functionality may still be stabilizing. You can check Slack’s latest status updates at https://slack-status.com/2025-02/1b757d1d0f444c34.

You should see a backlog of Slack alerts and notifications coming through, and rest assured that your environment remained fully monitored, and our team continued investigating and responding to alerts in real time throughout the outage.

As of now, we’ll resume normal communication with you via Slack or Microsoft Teams, but should Slack service experience interruption again, you can expect us to contact you via email. For further updates, please visit the Expel Workbench status page at https://status.expel.io/. If you have any questions related to the backlog, please contact your Customer Success Manager.
Posted Feb 26, 2025 - 14:41 EST

Update

We are continuing to monitor this outage, but some messages have started to send again. All missed notifications will be sent when Slack is fully operational. We will provide an update on this incident no later than 3:00 PM EST
Posted Feb 26, 2025 - 13:59 EST

Update

The Slack outage is ongoing and we are monitoring for any updates on the status of the outage. Workbench and SOC continue to be fully operational. We will provide an update on this incident no later than 2:00 PM EST
Posted Feb 26, 2025 - 12:59 EST

Monitoring

The outage in Slack is ongoing and we continue to monitor the situation for any updates. Customers can reach out to us via email or phone. The SOC continues to operate within Workbench to full capacity and Workbench is fully operational, all notifications will be sent when Slack comes back online.

We will provide an update no later than 1:00 PM EST.
Posted Feb 26, 2025 - 12:00 EST

Identified

Slack is experiencing an outage, which is preventing us from sending any notifications via the service. Other notifications are sending as expected. We are monitoring the issue and will provide an update no later than 12:00 EST
Posted Feb 26, 2025 - 11:26 EST
This incident affected: Notifications (Slack).