Delayed Notifications

Incident Report for Expel, Inc.

Resolved

The incident has been resolved, and all systems are once again fully available. No customer data was lost, and SOC operations were not impacted.
Posted Feb 18, 2025 - 09:51 EST

Identified

We have identified an issue with our vendor causing delays in our notifications system. SOC operations and alert ingestion are NOT affected. We will provide another update by 10AM ET.
Posted Feb 18, 2025 - 09:07 EST
This incident affected: Notifications (Email, Slack, Teams, Ticketing systems (via email, such as Jira), PagerDuty, Opsgenie, ServiceNow).