Phishing submission ingestion degraded

Incident Report for Expel, Inc.

Resolved

We've ingested all emails and all systems are operational.
Posted Mar 27, 2024 - 08:54 EDT

Monitoring

This issue appears to have resolved and we're working through the backlog of emails. We'll be monitoring this while we work through our backlog and will post an update by 10am.
Posted Mar 27, 2024 - 08:48 EDT

Update

We are still working to resolve this issue with our service provider. We'll provide another update by 10:00am eastern.
Posted Mar 27, 2024 - 08:30 EDT

Identified

We've identified the issue being a service failure with an external vendor. We'll provide an update by 10:00am Eastern.
Posted Mar 27, 2024 - 04:26 EDT

Update

We're still investigating the issue causing failures when ingesting manually submitted Phishing submissions. We'll provide an update by 4:45am.
Posted Mar 27, 2024 - 03:42 EDT

Update

We're still investigating the issue causing failures when ingesting manually submitted Phishing submissions. We'll provide an update by 3:45am Eastern.
Posted Mar 27, 2024 - 02:56 EDT

Investigating

Phishing submission ingestion is currently degraded. We are actively investigating the issue. We’ll provide an update by 3:00am Eastern
Posted Mar 27, 2024 - 02:15 EDT
This incident affected: Phishing submissions.